How to fix curl errors in R

If you encounter “curl” error when installing any packages in  “R”, follow these steps

Install  libcurl-devel 

  1. $ sudo yum install libcurl-devel  (RHEL / Centos)
    $ sudo apt-get install libcurl-devel (Ubuntu)Invoke R in sudo
  2. $ sudo -i R
  3. > install.packages(“forecast”)  or  install.packages(“forecast”, dependencies=True)

Wait for installation to complete and verify installation as follows.

4.  > library(forecast)

Bingo !! all done.

Leave a Reply

Your email address will not be published. Required fields are marked *

*